3nastri, realizzazione sitiweb, grafica a Roma.

Creare blog aziendale, locandine, carta intestata, biglietti da visita personalizzati.

Wordpress Internal Server Error, errore 500

3nastri, realizzazione sitiweb, grafica a Roma.

Creare blog aziendale, locandine, carta intestata, biglietti da visita personalizzati.

Home » WordPress Internal Server Error, errore 500
WordPress Internal Server Error, errore 500

WordPress Internal Server Error, errore 500

3Nastri Tag: Vedi tutti i 118 commenti

Questo errore capita frequentemente soprattutto nelle fasi di aggiornamento di WordPress o durante lo spostamento del proprio spazio da un host ad un altro.

Se sei un cliente Aruba segui questa piccola guida:

Questo è il messaggio di errore di Aruba: Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, postmaster@tuosito.it and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Il messaggio HTTP 500 – Errore interno del server è senza dubbio uno tra gli errori più odiati da utenti e soprattutto sviluppatori.
Questo errore in realtà dice tutto e niente e crea solo panico tra gli utenti meno esperti.
Il codice http di questo errore, il 500, è generato dal webserver quando un errore di elaborazione ha impedito il corretto completamento della richiesta.

Cosa fare per ripristinare il sito?
A) Adate su aruba e fate l’accesso dall’apposito pannello. Inserite i dati e captcha e poi cliccate su accedi.

Vedi immagine

 

 

 

B) Ora andate su Pannello gestione Hosting Linux.

Vedi immagine

 


C) Cliccare sul pulsante Riparazione Permessi che è il 4° a destra.

Vedi immagine

 

 

D) Ora andate su Riparazione Permission.

Vedi immagine

 

 

E) Si aprirà un bel popup su cui dovrete solo cliccare ok.
Fatto questo tutto tornerà alla normalità.

 

Vedi immagine

 

 

Se non siete utenti Aruba allora seguite questa procedura:

9 volte su 10 questo problema si risolve semplicemente andando a fixare il file di Htaccess. Questo file si può corrompere durante gli aggiornamenti di wordpress, dei plugin o durante il caricamento dei media (anche se è più raro).

1) Andate sul vostro FTP.

2) Salvatevi una versione attuale del file htaccess su una cartella (questo per questioni di sicurezza, se la procedura non dovesse funzionare potete ripristinare questo file).

3) Cancellate ora il file htaccess dal vostro spazio web.

4) Ora create una copia di questo file sul vostro desktop dal file salvato precedentemente, aprite il file (anche come txt) e cancellate tutto il contenuto. Salvate e fate l’upload di questo nuovo file sul vostro sito.

Ora il sito dovrebbe essere tornato a funzionare.
L’unico problema potrebbe essere sui Permalink.
Lo risolviamo facilmente.

Andiamo nel nostro pannello di wordpress. Impostazioni. Permalink. Scegliamo da Impostazioni comuni la modalità di visualizzazione dei link (io ho scelto Nome e mese). Salviamo e il gioco è fatto.

Se però il vostro file htaccess non è scrivibile perché non ha i permessi abilitati (chmod) WordPress vi darà un codice da inserire all’interno del file. Il codice lo troverete poco più in basso nella pagina del permalink.

Ora non resta che copiare quel codice nel vostro file di htaccess.

Riandate nel vostro spazio. Salvate nuovamente il file htaccess sul vostro pc e inserite quel codice.
Salvate e rifate l’upload.

Ora tutto dovrebbe funzionare.

Questa guida non risolve tutti gli Internal Server Error che possono capitare. Questa però è sicuramente la prima cosa da fare prima di cercare altre alternative.

[adsense1]

  • Daniele

    Grazie ora funziona, grazie molte… era 4 o 5 ore che ci lavoravo!

    • SergioTrenna

      Un commento fa sempre piacere!

  • Felici di esserti stati di aiuto!

  • Ercolla

    ho avuto questo problema con l’aggiornamento alla ver.3.4 e l’ho risolto seguendo le tue istruzioni.
    Grazie 🙂

  • Prego!
    🙂

  • Alexblog

    Grazie a queste tue informazioni, trovate al volo sul web, ho risolto il mio problema in un attimo. Dopo aver avuto un attacco di panico, multiplo!!!:-)

    • È capitato anche a me, e mentre cercavo questa soluzioni continuavo ad avere le palpitazioni 🙂

  • Enzo

    Caspita io invece non sono ancora riuscito a risolvere!

    • Spiegami di più magari riesco ad aiutarti…

  • Enzo

    Grazie della tua disponibilità ma ho risolto, spiego il tutto magari può tornare utile a qualcun’altro se è fuori luogo cancella pure… Nel mio caso non era un problema di htaccess ma di superamento del numero massimo di processi supportato dal server. Il cliente ha molti dispositivi (iphone ipad MacMail ecc…) con decine di email attive sul suo dominio ed avendo impostato su tutti il download automatico delle email ogni 15 minuti ha superato il numero massimo di 25 processi consentiti dal server. Soluzione contattato l’assistenza dell’hosting che ha subito sbloccato il tutto e mi ha raccomandato di impostare solo lo scaricamento manuale della posta.

    Magari fossero solo le palpitazioni a pochi giorni dall’attesa partenza per le ferie…. Mia moglie mi avrebbe ucciso!!!

    • Certo che può essere utile.
      Spesso un problema può dare fuori lo stesso errore e uno ci sbatte il capo tanto tempo prima di risolvere.
      Felice che tu ci sia riuscito!
      Buone ferie!

  • grazie per il post, molto utile e chiaro!

    • Felice che ti sia stato d’aiuto!

  • Alberto

    Grande! utilissimo

  • Alberto

    Avevo intuito che fosse un problema di permessi…ma cosa c’era di sbagliato che doveva essere resettato?

    • Grazie!
      Ma non saprei è una cosa tutta di Aruba.
      Su altri fornitori di host la cosa non accade.
      È proprio una procedura che va fatta dopo l’aggiornamento, anche se non sempre capita.

  • Virginia

    Ciao!
    Io, da veterana di joomla ma ignorante di wordpress, non so dove trovare il file htaccess. Non so nemmeno su che server siano appoggiati perchè mi hanno appioppato il sito da nulla… mi sapresti aiutare?

    • Il file .htaccess si trova nella root ovvero deve è installato joomla. Per avere accesso a quel file devi per forza sapere dove è appoggiato il sito (che host) e accederci tramite ftp o il fornitore dell’host.
      Altrimenti nn puoi fare nulla.
      Per vedere l’host e i dati dell’intestatario del dominio vai su: http://who.is/
      inserisci il dominio e verifichi.
      Almeno hai una base di partenza.
      Ciao!

      • Virginia

        Ciao!
        Ho controllato e non c’è. Il dominio è stato acquistato da TopHost, una società di Roma dalla dubbia serietà.
        Qualche altro suggerimento? :/

        • Se il file non c’è puoi crearlo.
          Se usi wordpress vai sulle impostazioni e poi su permalink. Spunti Mese e nome e salvi.
          A quel punto il file si crea automaticamente.

          Occhio che su tophost tutti i file sono nella cartella:
          /htdocs

          quindi il file deve essere li dentro.

          • Virginia

            Niente, non è stato creato nessun file htaccess :/ lo creo io?
            Scusami per il disturbo!

  • Si se non c’è crealo, ma con i permalink dovrebbe crearsi è strano.
    Hai controllato di essere nella cartella /htdocs?

    • Virginia

      Si, ho controllato più volte. Anche a me a questo punto sembra strano! Lo creo vuoto in txt?

  • Si ma sicuramente non ti fa creare un file .htaccess rinominando.
    Quindi crei un file txt e ci scrivi dentro i parametri.
    Poi carichi quel file sul tuo sito tramite ftp o con programmi appositi (io uso Filezilla) e lo rinomini lì.
    Fammi sapere.
    Ciao!

    • Virginia

      Ok, ci provo…ma cosa scrivo? Scusami l’ignoranza :S

      • allora guarda così è difficile capire le cose.
        Hai wordpress?
        Hai questo errore?
        L’unica cosa che posso dirti è di scrivermi su:
        info@3nastri.it
        e inviarmi i dati di accesso.

        Così per me è più facile capire qual’è il problema e perchè non ti crea il file .htaccess…

        Ciao!

  • emanuele

    sei un grande..!!!

  • Santo subito.

  • Valentina

    Ciao! Ho letto gli entusiasti post precedenti e ti chiederei cortesemente un aiuto. Ho lo stesso problema di Virginia. Accedo all’area FTP dov’e’ appogiato il mio sito e non trovo nessun file .htaccess. Non riesco neanche ad accedere al wp-admin: stesso errore 500. Grazie anticipatamente.

    • su che host sei?
      Guarda scrivimi su info@3nastri.it
      lasciami i dati di accesso e vedo che riesco a fare.
      Ciao!

  • cris

    ciao ho un problema, non riesco ad accedere come amministratore al mio sito, mi da Errore HTTP 500 (Internal Server Error): Si è verificata una condizione imprevista durante il tentativo del server di soddisfare la richiesta.

    ho seguito la tua procedura ma nulla, io sono ospitata su misterdomain.eu, ho scritto all’assistenza e non ho ricevuto risposta. Sono nel panico, non posso aggiornare i post e vedere le statistiche

    • non lo conosco…
      dammi qualche info in più e magari passami i dati su info@3nastri.it e vedo se riesco ad aiutarti.
      Ciao

  • Grandissimo!!!
    Si è liberato un posto da Papa, ti propongo.

    • SergioTrenna

      🙂

  • Fabio

    io ho incontrato questo errore 500, dopo aver aggiornato un tema e aver provato a lavorarci, caricando delle immagini per uno slide, al momento mi ha dato un errore ma nn gli ho dato peso il giorno dopo nn mi apriva più wp ne la pagina del sito dando l’errore 500. Aggiungo che wp è istallato in un sottodominio nel dominio principale ho un sito joomla. Comunque fino a quando nn ho fatto casino con le immagini dopo aver aggiornato il tema, sembrava funzionare tutto bene, ora ho provato a reistallare wp con nuovo database e funziona appeno ricarico il tema e applico il tempa si blocca tutto, potete aiutarmi!!! 🙁

    • SergioTrenna

      Guarda mi sembra evidente che è quel tema che non va. E non devi reinstallare WP ma semplicemente cancellare il tema usando una cosa tipo Filezilla per gestire l’ftp. I temi non sempre funzionano, spesso conflittano con qualche plugin oppure sono troppo vecchi per le nuove versioni di WP. L’unica soluzione che mi viene da darti e di non usare quel tema.
      Dove lo hai preso?

      • fabio

        comunque appena aggiornato funzionava, dopo che mi ha dato un errore che stavo provando a caricare delle immagini per uno slide è andato in tilt, pure se ricarico la versione non aggiornata, stranissimo non è che hanno cambiato qualche cosa al server, perche anche sul altro mio sito in un sottodominio blocca tutto, ma è funzionato per settimane ????? cmq il tema di yithemes è bello articolato o sentito e mi hanno chiesto di aprire un ticket x verificare che sembra strano questo comportamento!!!
        si cancello così però non capisco come mai di colpo questo rifiuto totale del tema

        • SergioTrenna

          possono essere plugin che conflittano col tema. Hai provato a disabilitarli? Guarda in questi casi le variabili sono molte. È difficile verificare dove sia il problema.

          • Fabio

            ma ho reinstallato Wp non ho aggiunto nessun plugin dall’installazione originale??

          • SergioTrenna

            Gaurda messo così è difficile aiutarti. Ma se con un altro tema funziona tutto a dovere, allora il problema è il tema che hai scelto.

          • fabio

            Capisco, quello che mi lascia perplesso e che ha funzionato per settimane!!! se nn funzionava dall’inizio l’avrei digerito meglio, ora mi hanno scritto stanno vedendo quale potrebbe essere il prob i realizzatori del tema poi ti faccio sapere, cmq per ora ti ringrazio della disponibilità!!! ;D

          • SergioTrenna

            Non è mai detto. Magari si è generato un errore.
            Figurati di nulla!
            Ciao

  • Angela

    grazie mille! chiarissimo, risolto al volo 🙂

    • SergioTrenna

      😉

  • Grazie. Ho risolto grazie alle tue spiegazioni. Semplici ed efficaci

  • Simone

    Grazie 1000!

    • SergioTrenna

      😉 Prego

  • cristina

    ma sei uno spettacolo! Grazie

    • SergioTrenna

      🙂

  • Chiara

    Mi hai salvata da un momento di panico!! grazie!

  • Francesco

    Ciao io ho wordpress con hosting TOPHOST e installando un plugin con template per landing page si è verificato questo errore…mi puoi aiutare? seguo la tua procedura? grazie

    • SergioTrenna

      se è dopo l’istallazione del plugin vai tramite FTP e cancella il plugin. A quel punto dovrebbe riprendersi

  • Francesco

    Perfetto tutto ok!! risolto grazie infinite sei un mito!!!

  • Mi è appena capitato installato l’aggiornamento a WP 7

    Grazie per la dritta!

  • electromania.co

    ciao articolo interessante … ma x me non ha funzionato … io arrivo da un trasferimento .. vecchio server register e nuovo server godaddy …

    nella nuova versione del sito … ho creato un nuovo db ho importato i dati del vecchio .. solo che il nuovo è dentro una dir /site/ … cosa che prima non era …. era nella root principale…

    se riuscissi ad entrare in admin cambierei (come faccio x altri siti) l’url … spostando poi il file htaccess ed index.php nella dir principale ma non riesco a farlo .. 🙁

    idee?

    • SergioTrenna

      devi entrare nel database (mysql) e cambiare i valori che su WP imposti dalle impostazioni su Indirizzo WordPress (URL). Su Indirizzo sito (URL) dovresti lasciare quello che c’è.
      Ma la cartella site l’hai creata tu o è preimpostata?

      • electromania.co

        ciao .. si la cartella l’avevo creata io … alla fine ho risolto spostando tutto fuori dalla dir site .. e tutto ha funzionato.
        immaginavo anche io .. l’installazione originale nel primo server era in root…

        🙂

        grazie!

        • SergioTrenna

          Figurati. Meglio spostare file che andare a toccare il DB soprattutto se non si è pratici 😉
          Ciao!

  • unonessuno

    Nel mio caso la procedura con Aruba ha funzionato.
    Grazie

    • Sergio Trenna

      😉

  • luca

    grazie mille!
    io ho migrato dominio diverso su hosting diverso (su aruba, ma è solo momentanea la cosa, poi andrà via… 😛 ) e mi dava quell’errore, ho provato prima soluzione su pannello di aruba, ma nulla, allora ho provato con l’htaccess… et voilà 😀 adesso va! grazie millle!!! 😀

  • Sergio Trenna

    Felice di averti aiutato!

    • luca

      una cosa ancora scusa,
      noto però che la gestione delle pagine della bacheca, quindi la gestione del wordpress da backend, è lentisima.
      mentre il sito diciamo che carica abbastanza normalemnte…
      hai mica mai riscontrato cose analoghe?
      nel senso, potrebbe essere che ora però il sito lato bacheca di wordpress sia lentissimo a caricare le pagine?
      grazie! 🙂

      • Sergio Trenna

        Allora il problema del backand lento è quasi sicuramente legato a qualche plugin o all’aggiornamento della piattaforma. Prova a disabilitare tutti i plugin e vedere se riprende la velocità normale. Se così fosse allora man mano li riattivi e cerchi di capire quale plugin dava problemi. Fammi sapere se risolvi

  • Angelo

    Grazie mille!! Mi hai salvato da un possibile disastro!! 🙂

    • Sergio Trenna

      Prego 😉

  • luigi

    GRAZIE MILLE

    • Sergio Trenna

      😉

  • Enri

    Grande,
    utilissimo articolo!

  • emiliano

    Salve,ho questo odiato problema su questo sito.Riesco ad entrare solo nella home e poi nientaltro.Oltretutto i contenuti della home non sono nemmeno uguali a quelli che avevo in locale.Mi puoi aiutare?
    Se vuoi ti posso passare i dati di accesso al plesk.

    • posso provarci ma mi serve capire meglio la situazione perché l’errore 500 può essere causato anche da altre cose.

  • Emanuele

    Sei un grande, svuotare il file .htaccess è stata la svolta, grazie mille!

    • 😉
      Ora però ricordati di impostare nuovamente il permalink!
      Ciao

  • Fabio

    Bravo, finalmente dopo 2 giorni di tentativi ho trovato la tua guida ed ho risolto! 🙂 Grazie mille!

  • katya

    grazieeeee!

    • SergioTrenna

      Prego 😉

  • Sara

    Ciao a tutti, mi si è presentato questo errore sul sito wordpress con hosting serverplan. Come posso risolvere?

    • SergioTrenna

      Ciao Sara dovresti descrivere meglio la situazione. Questo errore dopo cosa è venuto fuori? L’aggiornamento di WP o di un plugin?
      O altro? Non conosco Serverplan. Hai provato a fare quello che c’è scritto nella guida?

  • MelficeXX

    Ciao a tutti! Ho un problema, sto sviluppando un sito in locale e sto cercando di trasferirlo dal fisso al portatile (appena acquistato). Ho eseguito la procedura già effettuata decine di volte su altri pc ma quando vado a lanciare il sito sul portatile mi si presenta l’errore 500. Database, username e password sono corretti, ho provato la medesima procedura sul portatile della mia ragazza è va tutto a modo. Può essere un problema di antivirus (c’è installato McAfee)? Come posso risolvere?

    Ps. Ho testato sia MAMP che xampp…

    Grazie

    Damiano

    • SergioTrenna

      In effetti è abbastanza strano quello che dici e onestamente non mi è mai capitato l’errore 500 lavorando in locale. Hai provato a cancellare il file htaccess? Te ne fai una copia e lo cancelli. Su quella nuova installazione di Xampp hai provato a creare un nuovo sito? Vedi anche questo e fammi sapere.
      Ciao

      • MelficeXX

        Ciao, era una bischerata. MAMP era settato con php versione 7.xx, l’ho rimesso in versione 5.6 ed è tornato tutto a funzionare… Grazie cmq per la risposta!

        • SergioTrenna

          Figurati! A presto!

  • Lorenzo

    Grazie mille perchè tramite i tuoi consigli ho risolto il problema!

    • SergioTrenna

      Prego! 🙂

  • Daniele Parlamento

    Ciao Lorenzo e grazie per l’articolo 🙂 io purtroppo non capisco il motivo ma non riesco a risolvere. Ho un sito multilingua e ricevo l’error 500 solo 2 lingue… hai suggerimenti? grazie mille anticipatamente

    • SergioTrenna

      Hai provato a fare quanto scritto sopra o non sei capace di farlo? Dammi più dettagli per favore. Come è successo? Hai aggiornato WordPress? Hai installato qualche plug?
      Per aiutarti ho bisogno di capire meglio.
      P.s. mi chiamo Sergio 😉

  • giuseppecostantino

    Ciao a tutti! Io uso Hostmonster ma non so da dove iniziare. Dove trovo il FTP? E come salvo il file Hatcess? Il sito ha smesso di funzionare dopo l’aggiornamento di una pagina. Help!

    • SergioTrenna

      Detto così è tutto troppo vago. Non uso e quindi non sconosco Hostmonster, ma quando ti sei registrato e hai pagato dovrebbe esserti arrivata una mail con tutti i dati di accesso anche FTP. O almeno dovresti avere delle credenziali per fare la login e trovare i dati. Il file in questione si trova nella cartella in cui è installato wordpress accessibile o da tfp (con ad esempio Filezilla) oppure dal pannelo del tuo fornitore hosting.
      Che significa che ha smesso di funzionare?
      Che errora hai?
      servirebbe almeno un link per vedere o informazioni in più.
      Saluti

  • Ciao ho un problema. Il mio sito è su Aruba (server linux) e il sito è principalmente su base WordPress.
    Mi è comparso il fantomatico errore 500 Internal Server Error…, che non mi faceva accedere a nulla di WordPress (ne lato “pubblico”, ne pannello amministrazione), solo la parte del sito Wiki.
    Siccome mi è già capitato (grazie anche ai consigli di 3Nastri), faccio la consueta procedura su Aruba, di “Riparazione Permissions”. Dopo un paio di tentativi si riesce nuovamente a vedere il lato “pubblico”, ma non appena faccio per accedere all’area riservata mi compare nuovamente il fantomatico errore 500.
    In sostanza ora non riesco ad accedere al pannello admin dell’area riservata. Cosa possa fare?
    Grazie per l’aiuto.

    • SergioTrenna

      Ma all’area riservata di cosa di wordpress o della wiki?
      E soprattutto hai installato una wiki nello stesso spazio di wordpress?
      Se è WP la cosa che mi viene da pensare è aggiornare tutti i plug. Se non va disattivarli (cancellali da FTP, ma magari prima salvateli).
      Non ti escludo che possa anche essere la wiki.
      Dovresti spiegarmi meglio perché così ho poche informazioni.

      Altra cosa prova a salvarti il file .htaccess e a cancellarlo.

      • Ciao, scusa ma pensavo fosse chiaro. Il problema è quando tento di loggarmi all’area riservata di WordPress.
        (per quanto riguarda il wiki, mediawiki è installato su una cartella a parte e non crea conflitto con il resto del sito, è così da 3 anni ormai)
        Proverò a cancellare/rinominare la cartella dei plugin… proviamo.
        Il file .htaccess in che cartella si trova?
        Grazie ciao

        • SergioTrenna

          Si prova con i plugin e vedi se la storia si risolve.
          Il file .htaccess si trova nella root dove sono le cartellle di installazione di WP e i file tipo wp-config.
          Ricordati che quando cancelli (fattene una copia) il file di .htaccess devi risettare i permalink dal pannelo di WP.
          Fai un check dei fai sia del tema che di WP e controlla che non ci sia codice strano all’interno.
          Se vedi codice strano puoi essere infetto e allora c’è da ripulire il codice e rimettere una versione pulita di WP e plugin.
          Fammi sapere.
          Ciao

          • Alessandra

            Ciao!
            io ho avuto lo stesso problema esattamente 20 gg fa
            fatto tutto:
            – ripristinati permessi da aruba
            – ripristinato htaccess
            – disattivati plugin
            nulla da fare
            Se accedo al pannello di amministrazione e voglio per esempio entrare in temi o menu o plugin mi dà questo errore 500
            AVete novità?

          • SergioTrenna

            Come è stato ripristinato il file htaccess?
            Per i plugin prova da ftp a rinominare la cartella plugin e vedere se smette l’errore.
            Mi servirebbe sapere qualcosa in più, per esempio se hai aggiornato qualcosa e che cosa.

          • Francesca Brusori

            Ciao, io ho lo stesso problema di Alessandra ed ho già fatto diversi tentativi da te consigliati qui sul form, ma niente ha funzionato!!! Da cosa può dipendere l’errore? Non riesco a entrare in temi, plugin, strumenti..

          • Francesca Brusori

            ciao sergio! Io ho lo stesso problema descritto da Alessandra. Accedo alla bacheca wordpress , ma se entro in Temi, Plugins o Strumenti , mi esce ERRORE 500 … Ho tentano le varie soluzioni da te proposte, ma non ho ottenuto nulla. Solo cambiando i nomi delle cartelle Theme e Plugins sono riuscita a entrare, ma ad ogni modo non si visualizza alcun tema e alcun plugin ed escono altri messaggi d’errore … Cosa posso fare??

  • Francesca Brusori

    Ciao, Io ho lo stesso problema riscontrato dagl’altri utenti. Riesco ad accedere alla bacheca di WordPress ma se entro in Temi, Plugins, Strumenti .. mi esce l’errore 500. Ho tentanto di risolvere seguendo tutte le varie indicazioni (rinomina cartelle.. file htacces.. ecc) Ho anche provato a reinstallare wordpress e reimpostare tutti i permessi , ma niente!!!
    Solo rinominando le cartelle Themes e Plugins (su FTP) ho avuto accesso alle sezioni , ma il problema resta perchè comunque non mi vengono visualizzati i vari temi o plugins e nemmeno posso effettuare la ricerca. (ho tentato anche di cambiare tema.. ma niente da fare)

    • SergioTrenna

      Dopo cosa è avvenuto questo errore?
      Hai aggiornato WP?
      Hai provato a cambiare prima solo il nome della cartella plug e poi quella del tema per capire se il problema è nel tema o nella cartella dei plug.
      Se è nel tema aiutarti è complicato perché bisognerebbe vedere che tema è.
      Se è nei plugin dovresti provare a verificare singolo plugin.
      Te li scarichi tutti i ftp e li ricarchi uno per uno e vedi quale è quello che crea problemi.
      Mi viene da pensare a plug che creano cartelle in ftp, ma possono essere tante cose.

      • Francesca Brusori

        In realtà il problema è sorto con la prima installazione di WP sul dominio. Infatti pensavo fosse colpa del server..
        Inizialmente non potevo nemmeno accedere alla bacheca, ma ho inserito queste due righe di testo nel file wp-config.php e sono riuscita ad entrare:
        define(‘WP_HOME’,’http://iltuosito.com’);
        define(‘WP_SITEURL’,’http://iltuosito.com’);
        Per Temi, Plugins e Strumenti invece mi da sempre l’errore 500 . Il sito è vuoto ed il tema attuale è quello base .. non è mai stato possibile cambiarlo perchè non è mai stato possibile entrare nei temi 🙂
        Non è il mio primo sito con WP e non ho mai avuto questi problemi!! Consigli?

        • SergioTrenna

          Ci deve essere qualche problema nell’installazione di WP.
          Sulle impostazioni hai toccato:
          Indirizzo WordPress (URL)
          Indirizzo sito (URL)
          ?

          Se hai toccato quello può essere quello che genera il problema. E dipende anche dalle cartelle all’interno dell’hosting come sono state messe, se sotto una sotto cartella.

          Sarebbe più facile vedere per capire perché capiscimi così è come tentare per un meccanico di farti riparare l’auto senza neache sapere cosa c’è nel cofano.
          Non è facile.

          • Francesca Brusori

            Si capisco e se ti va di dare un occhio, non ho problemi a passarti le credenziali .. dimmi solo come !

            Comunque ho provato a fare l’istallazione via Aruba, via FTP, via pannello di controllo …. Sempre ottenuto lo stesso errore 🙁

          • Francesca Brusori

            No, una volta caricate le cartelle ho solo inserito i dati del server.
            Se ti va di dare un occhio per me nessun problema .. basta che mi indichi come passarti i dati !

          • Francesca Brusori

            No, una volta caricate le cartelle ho solo inserito i dati del server.
            Se ti va di dare un occhio per me nessun problema .. basta che mi indichi come passarti i dati !

          • SergioTrenna

            Mandami una mail su info@3nastri.it, ma prima di domani non riesco a vedere nulla perché sono carico di “cose all’ultimo momento”.

  • Ciao io ho un problema simile!Conoscevo già la prima soluzione che di solito avveniva quando WP faceva un aggiornamento e automaticamente chi era cliente aruba perdeva i permessi, da qualche tempo hanno per fortuna sistemato questa cosa e nelle ultime versioni non mi ha più dato questo inconveniente. Ora il mio problema è che nonostante non ho fatto nessun aggiornamento, ho provato anche a riparare i permessi, non ho aggiunto nuovi plugin sul mio wp mi da comunque l’errore. Cosa ancorra più grave è che non posso nemmeno accedere al wp.login.php non so come fare!potete suggerirmi qualcosa?
    Grazie mille

    • SergioTrenna

      Allora il problema credo sia diffuso. Anche qui come sempre mi servirebbe qualche info in più.
      È un vecchio sito o una nuova installazione?
      Che plugin ci sono?
      Cambiando nome a cartella del tema e al plug il sito funge?
      Sto provando a risolvere il problema per una persona e nel caso funzioni prosterò qui come fare.

      • Grazie Sergio!
        Il sito è nuovo hosting Linux preso da aruba 3 anni fa, sempre aggiornato ogni mese per questione del mio lavoro.
        Sto anchio controllando i plug in anche se non ho aggiornato o aggiunto niente non vorrei che sia successo qualcosa.
        Attendo un tuo feed in caso risolvi l’altro problema!

        • SergioTrenna

          Sicuramente è un problema di versione di php.
          Devi cambiare versione PHP dal pannello di controllo Aruba.
          Prova e fammi sapere.
          Contattate anche il servizio clienti aruba che risponde sia ai ticket che al tel.
          Io da qui non posso sapere tutte le cose perché non lavoro su Aruba.
          Fammi sapere se anche tu risolvi con l’aggiornamento del php perché è una cosa a cui non avevo pensato e che i tecnici di Aruba hanno dato come soluzione e chi mi ha chiesto aiuto qui.
          Ogni aggiornamento può essere utile agli altri.

          • Infatti!Ho aggiornato il php all’ultima versione ed è tutto risolto!grazie mille
            Al servizio clienti mi hanno detto che è un errore che si stanno avendo molti utenti
            grazie mille Sergio

          • SergioTrenna

            Di nulla 🙂

  • Mi unisco “allegramente” anch’io al problema. Ho un dominio su hosting linux aruba, chiaramente.
    Purtroppo non sono la più sveglia della cucciolata e mi sono accorta del problema soltanto negli ultimi giorni perché andando nelle sezioni Aggiornamenti, Plugin mi compare l’errore 500 (inoltre ho notato che la pagina di Akismet è totalmente bianca).

    La pagina sui Temi invece si comporta in modo strano. Mi da l’errore 500 al primo tentativo di accesso, successivamente mi fa entrare e mi mostra normalmente i temi installati. Sembrerebbe tutto normale, tranne che se gli chiedo di mostrarmi i temi disponobili per aggiungerne di nuovi, non riesco a vedere nulla e la pagina è bianca.

    E’ come se il blog non ricevesse “le novità” dall’esterno, e infatti in quel momento ho realizzato che era almeno un mesetto che wordpress non mi segnalava aggiornamenti di nessun tipo: nè per i plugin, nè per i temi.

    Ho quindi fatto un aggiornamento manuale tramite FTP, ma ancora niente. Ho riparato i permessi loggandomi nel mio profilo di aruba (come si doveva fare un paio di anni fa), ma ancora niente. In ultimo, non so se può essere collegato, ma di solito – quando ricevo un commento tramite di Disqus -, poi tale commento viene memorizzato anche nel database “normale” di wordpress, l’ultimo che ho ricevuto – ossia in questo periodo dove non ricevevo notifiche di aggiornamenti – invece no.

    • SergioTrenna

      Devi sicuramente anche tu aggiornare le versione di PHP dal pannello Aruba.